What's new
What's new

2005 SHARP SV-2412 the Y axis has a 1.920" offset position

GENARO ROBLES

Plastic
Joined
Mar 31, 2022
My Sharp SV-2412 has a Fanuc Oi Mate-MB controller and never had any problem in 3 years, well until now.

I had a Y axis overtravel alarm so I replaced the old limit switch by a new one(SN02D12-502-MC), but the Y axis overtravel alarm still there.

I noticed that the Y axis position on the screen is wrong because the table never reached the limit switch, so I changed the "Y" soft limit 1+ (parameter 1320) from 2,000 to 54,000 and now I can get the table move to the home and "stroke end" switch.

I used a voltmeter to test limit switch and is working OK, actually I was able to see that the Y position has a 1.920" offset to the screen position reading.

Can anybody tell me how can I set the correct position reading of the Y axis?

or how I can reset the encoder position to the factory default parameters?

Thanks
 
So, question, does this machine have absolute pulse coders? Do you have to home out the machine every morning or does it remember where it is when you power off and back on?

Another question, do you have any value in G53 on your offsets page?


If the new switch was the culprit I would expect you to maybe be off location by 1 turn of the ballscrew, if it wasn't put really close to the previous location. But 2 inches is a lot.



If you do have absolute pulse coders, you need to find the instructions on re-homing it. That includes changing a bit on parameter 1815, cycling the power, then re-homing.


Simply getting a y axis overtravel alarm (a soft alarm) doesn't tell me it is switch related, unless the machine isn't where it thinks it is.
 
I have a 2005 2412 the machine has absolute encoders and limit switches.
you need to do a reference point setting.

Open the left door look at the lower saddle and you will see a bracket with a red arrow on it
Line the arrow up with the other arrow
under it. This is where home is.

Now do a Reference point setting.
This is what Sharp sent me to do my machine.
Change PWE TO 1 (write)alarm will sound
confirm parameter 1002 bit 1=1 (second bit from the right)
confirm parameter 1815 bit 5=1(sixth bit from the right)
Change parameter 1815 bit 4 to 0 (fifth bit from the right)
check parameter 1320 and 1321 and record settings.
change parameter 1320 to +99999999 and 1321 y only to -99999999.
turn off power to machine
turn power back on
line up the arrows on the y axis using the MPG
change parameter 1815 bit 4 back to 1 y axis only
turn off power to machine
turn power back on
place the rapid knob to F0
zero return y axis using y+ button
change parameters 1320 and 1321 back to the original settings recorded earlier.
change PWE back to 0

You may know this, bits are read on a fanuc control right to left starts with 0
76543210
so bit 4 you would count from the RIGHT to the left
76543210 so the 5th place number is bit 4.

I wonder if one of the couplings on the motor
or the ball screw spun .
I would check them.
 
I'm Sorry for my late response.

- Yes, I have to home out my machine every morning.

- I don't see the G53 values, I can see G54 to G58. G54 X=-22.7160 Y=-2.1937 Z=0.0, all other "G" are "0"


When the machine was OFF I turned the Y axis leadscrew to the home position checking when the home limit switch went from 0 to 1 and now the display readings are OK.

But I still having the Y overtravel alarm. I will follow the re-homing procedure provided by Vcmt member.
 
Hello Vcmt and I'm Sorry for my late response.


When the machine was OFF I turned the Y axis leadscrew to the home position checking when the home limit switch went from 0 to 1 and now the display readings are OK.

But I still having the Y overtravel alarm.



All bits in 1815 parameters are "0"

Can you please explain me how to perform how to perform the "zero return y axis using y+ button" procedure?
 
First make sure your machine has absolute encoders
Open the cabinet door and the main control about a foot square in the middle of it is
a battery box about 3 inches square. If it has this the machine has absolute encoders.



On my machine 1815 bits 4 and 5 are 1
on all axis
Check the parameters in your manual.


Go to the mode switch and turn it to ZRTN.
Then press the +y button and hold. It will rapid to Y home.

You can also send y home go to mdi and key in
G53 Y0 and press cycle start and this will send Y home.
 
Good Morning Vcmt,

There is no battery on the main control, Do I have to follow the "new zero reference" procedrure you sent me before?
 
Good Morning Vcmt,

There is no battery on the main control, Do I have to follow the "new zero reference" procedrure you sent me before?

Your machine does not have absolute encoders
that strange mine is the same year as yours.
don't do the encoder reset i sent you.
call sharp and talk to them.

If it doesn't have absolute encoders why doses it stop before
it hits the limit switch.


Please let us know what they say
 








 
Back
Top