What's new
What's new

Drip feeding to 2005 VF2 with 4th axis - how does the buffer work?

Springy

Plastic
Joined
Oct 22, 2021
We are trying to dripfeed to our 2005 VF2 with HRT210 rotary. We've got it "up and running" sort of, but it frequently (not always) reaches a point where there is some kind of error that prevents it loading any more code, so it'll just sit in position with the spindle running but no other motion happening. It does not always happen at precisely the same place but it often happens in around the same region of the program. We've played with the baud rate settings with no real obvious success, but we've basically found:
1. 9600 - too slow, can't load code fast enough, machine looks like it's running at 50% feed/rapid
2. 115200 - never got it to run through even once
3. 19200 - recommended Haas setting, worked fully a few times but not every time.
4. 38400 - what we are currently using, seems about the same as 19200 - has run through a few times but has also errored out as many times as it's run cleanly.

What do we need to look for here? How do I tell whether the connection is dropping entirely or the baud rate is just too slow and that's causing some other issue?

I guess it might help if someone can explain exactly how the buffer works - are we overloading the machine's DNC buffer, or are we starving it by not getting enough data in there fast enough? In other words, would it help if we put dwells in that allow the program to buffer more?

Let me know if there's any additional information I can post up that might help with diagnosis. Program is about 3hrs runtime and has a reasonable amount of low-resolution (ie not mold making) 3 axis profiling work. 4th axis is indexing only.
 
its been a long long time since I've ran a Haas (2004-5?) so grain of salt here

But the baud rates just have to match, and its a matter of making your PC/laptop match with the options available on the mill and vice versa, back in the day there were only like 1-2 combinations depending on the platform used... (though faster is always betterer)

anyway, the laptop/pc has to stay open the entire time, can't really be doing anything but DNC to the mill, any hiccough in sending signal will cause the mill to "forget" where its at. So my educated and braindamaged guess is that its something on the puter side causing an interruption, cable, wi-fi, RS-232 port funkyness or the puter is going into sleep mode, 3hrs is a long ass time to DNC...

If memory serves the DNC would load like a page of code in advance, or a set # of lines, regardless of baud rates, its whatever the machine can handle... lots of hemstitching at crazy high feed rates might cause it to get funky too.

Might try deleting any unused programs from the mill, help free up some space, its a long shot, but it might just work.
 
I seem to recall there was a trick about running your DNC software in "realtime mode" or something like that, to avoid timing hiccups caused by multithreading. Last I had to do serial was in Windows XP.
 
I have not had any luck with communication above 9600 on my VF-2. That's what I'm running the downstream rotary control at and that's what I run the drip feed box at. My guess is there's too much noise from all the other electronics. I might need to drill a hole in the foundation for a better grounding rod right next to the machine or something similar to get higher. I've never had anything higher than 19.2 work, even in the modem days on my home computer.
 
Thanks everyone. We are using a straight COM port not a USB adaptor. PC is not connected to wifi/internet while drip feeding. Cable is 15ft long, that’s as close as we could get the computer. Baud rates are always set the same at computer as at the control. We have only our spindle warmup program stored in the control currently, so 99% of memory free.

We are using HyperTerminal to run the DNC. Not sure how to enable “real-time mode” on that? But appreciate the suggestion, I’ll take a look.
 








 
Back
Top