What's new
What's new

Drip feeding Yasnac J300

Antoine21130

Aluminum
Joined
Oct 19, 2023
Hello everyone,

Recently managed to send programs via RS232 to my yasnac J300 (on a Matsuura MC-660VG) but the small memory limit is quite annoying so I’m trying to drip feed.

I select remote mode (similar to tape mode I think) then input my prog number and control display “search”. I then send the program with DNC4U using software flow control and the beginning of the program is loaded.

After pressing cycle start, machining start but stops after few hundreds of lines. It always stop in the middle of the same line and doesn’t throw any error code.

Seems like DNC4U is waiting to send the rest of the program.

Any idea on that one might be helpful.

Thanks
 
Thanks for the help, somewhat managed to make it work but hard to start the process, David Scott what’s ur process for starting the communication ? I select Tape mode (remote mode) then start sending from DNC4U (which wait for Xon signal) then I press cycle start on the CN. Sometimes it start the exchange and everything works great, but sometime it doesn’t start the transfer from DNC4U.
It also sometimes trigger an alarm 0125 (no M02/M30 but there is one) the only way to get the communication working again after error is to restart the J300.
 
Thanks for the help, somewhat managed to make it work but hard to start the process, David Scott what’s ur process for starting the communication ? I select Tape mode (remote mode) then start sending from DNC4U (which wait for Xon signal) then I press cycle start on the CN. Sometimes it start the exchange and everything works great, but sometime it doesn’t start the transfer from DNC4U.
It also sometimes trigger an alarm 0125 (no M02/M30 but there is one) the only way to get the communication working again after error is to restart the J300.
I suspect that its a Handshake issue. When using Xon/Xoff (Software Handshaking), you need to ensure that the Control Parameters for RS232 Comms is set to use DC Control Characters.

Hardware Handshaking is always more reliable for DNC exercises, but means building, or buying a cable configured for Hardware Handshaking. I prefer to make the cable, as I then know that its correct.

Regards,

Bill
 
Thanks for the help, somewhat managed to make it work but hard to start the process, David Scott what’s ur process for starting the communication ? I select Tape mode (remote mode) then start sending from DNC4U (which wait for Xon signal) then I press cycle start on the CN. Sometimes it start the exchange and everything works great, but sometime it doesn’t start the transfer from DNC4U.
It also sometimes trigger an alarm 0125 (no M02/M30 but there is one) the only way to get the communication working again after error is to restart the J300.
I select DNC mode, it's a Kitamura and that is what they painted on the control, press cycle start, and then start sending the program from my computer, which may be your problem. I am sure I read this in the Yasnac manual. You have them all I hope? If not then go to Yasnac's website and download them all, for free, anytime you want. They are the gold standard where access to all of the literature on their products is concerned. While you are at it you may want to download the operator's manuals for the i80 too. The communications parts are the same for both but not all of the information is in both.

I should add that I have mine wired for hardware handshaking but need to set both the control and DNC4U for both hardware and software handshaking. Mine is wired straight to the card in the cabinet since the previous owner removed the cable between the card and the external serial port.
 
Last edited:
Thanks everyone for all the help ! Managed to dripfeed a 3MB program today without any issues using software flow control. Pressing cycle start after sending from PC was the issue. Using the starting process from DavidScott worked perfectly.
Thanks again !
Best regards,
Antoine
 








 
Back
Top