What's new
What's new

Haas VM2 Network Setup - Windows 7

ChadLepto

Plastic
Joined
Nov 1, 2012
Location
Canada
Hi Guys;

I've been trying to get our VM2 setup in our network. The instructions seem very straightforward....

We let the machine automatically pull IP settings via DHCP and can setup the Netshare option just fine.

However, getting the VM2 to show up in the Windows 7 network is a totally different story. :(

So, netshare works, we can ping the machine (192.168.1.118), we can access the machine via web browser - BUT the VM2 simply won't show up in the Windows 7 network (on any of our workstations) and thus we can't map the harddrive of the VM2.

We have tried:

1. Open Control panel
2. Open Administrative tools
3. Double click Local Security policy
4. Double click Local policies
5. Select Security Options
6. Search for "Network security: LAN Manager authentication level" double click it, select from pulldown menu "send LM & NTLM responses"

It didn't work.

We also tried the HAAS/ABCDE user/pass combination but it also did not help.

It seems to be somewhat of a known issue with Windows 7 as you can find quite a few people online who have had similar problems with the setup. Any help on how to resolve this would be much appreciated!

Cheers,

Chad
 
Networking Win 7 (and HAAS)

The issue is mostly with Windows 7- that has crap and different local network sharing (they changed lots of things for no good reasons. A lot of hw is affected).
Its not necessary for it to show up in the network, for the network hard drive mapping to work.

You will probably need a user on the local machine- ie the username of the VM2.
You can do this from a command prompt - and unless it works from a command prompt no way will it work graphically.
Start command prompt.
(Start/all programs/command prompt)
Use the older (dates back to lanman days, in 199x or so) command prompt syntax.

net use \\192.168.1.2\vmshare /user:uname
You may use the name or the ip.
The ip is likely easier to get to work.
The user:uname is optional and may not be needed. This is the username *on the VM2*.

The above is an easy shortcut.
Its also useful to make a share on the network, to which the VM2 can connect.

The whole local networking things is horrendously crippled - because MS in their total lack of wisdom changed a lot of stuff from how its been working for over 15 years.
Ports, authentication format etc.
The same affects network printers, scanners, shares globally.
Its a big mess.

If you cant get it to work, I can try to help with a remote network connection (teamviewer etc) if you want.
PM for details.
I´m in Barcelona, Spain, and its now 7:50 am. I will be back in about 3 hours.

Use this command to check syntax.
net use /?


For troubleshooting purposes, test with shares from one PC to another.
When you can connect from PC1 to PC2 and vice versa, you can also connect to the HAAS VM2.
If you cannot connect from one PC to another, you probable cannot connect to the VM2 either.

It may make sense to make sure
- the local names are being resolved
- names mapping is enabled in cleartext
- it may make sense to use a hosts file with static ip addresses

I always ditch dhcp. I also use wired everything.
Neither of above is strictly necessary, but they make life a lot easier.
You can also use a LMHOSTS file, and optionally statically map the MAC address.
Both help, when (its likely) some parts of the total local networking stack arent "right".

Sorry this is dense, but its a wide, complex field.
For setup purposes, it will help to disable all firewalls, including windows firewall.

YOU MUST ENABLE SIMPLE FILE SHARING IN WINDOWS 7.

Its much easier to troubleshoot this from an open network to one with firewalls enabled.
You will then need to allows specific ports & ips in the firewalling sw, if any is used.

Once you have the right syntax, it takes less than a minute to connect a new PC to the VM2.
I have not tried, but am pretty sure the same problems exist with other brands VMCs in exactly the same manner.
The problems is with Win 7 and not the HAAS.

They certainly do with OKI network printers and HAAS machines.
Good luck, best, Hannu
 
Last edited:
Wow - Thanks Hannu for the great reply - I'll give this a try first thing tomorrow morning and let you know!

I'm in Vancouver (PST) so should be 9 hours behind MET. I may take you up on your Teamviewer offer though if I run into problems... ;-)

Cheers,

Chad
 
Hi Guys;

So, after a bit of troubleshooting this is where the cat is burried.... Mapping the network drive works great (even through Windows) once you know the correct path, which is: \\[HAAS]\DATA

Replace [HAAS] with the machine name you have configured in the Haas Control on line 900. Connecting takes a few seconds and works flawless! :D

So, afterall - It's the [\DATA] that's simply not documented properly....

Cheers,

Chad
 
Last edited:








 
Back
Top