What's new
What's new

Hardinge HLV-H Coolant Pump/Motor

BAJ

Plastic
Joined
Feb 2, 2013
Location
Robbins, NC
I'm working on a 1985 Hardinge HLV-H and for the life of me can't figure out how to get the coolant pump motor off. The sump was slam full of chips and dried congealed coolant and I'm afraid to run the pump until everything has been thoroughly cleaned out. I started off unbolting the motor from the cabinet from the top and then took the other bolts loose from the bottom. I thought the long piece (#1 in pic) would slide off the motor shaft after unbolting but no luck. Then I took the bolts off that connect the shaft to the actual pump (#2 in pic) but can't get it off the shaft either.

What am I missing? I have sprayed everything with ballistol to help loosen it up and gently tapped, pulled and pried on everything. I've been afraid to really beat it hard for fear of breaking something.

Thanks,
Brian

1711938318767.png
 
The pumps that I have seen are simply screwed thru the motor flange (from the top) into a tapped flange on the chip pan, with allen screws. Maybe give the flange on the top a good whack with a hammer, might be stuck with crud and paint. Then the whole assembly just pulls out from the top. You might need to remove that pipe/hose fitting to pull it thru the top.
I just removed one from a DV59. I have an HLVH, and have never used the coolant pump; unless one is doing production, squirt bottles and brushes work, with a lot less mess. Cheers.
 
Last edited:
As far as I know coolant should never be used on any HLV-H. The hardened wear strips and composite way under the carriage are glued in. If the coolant breaks the bonds down you will have to have the machine rebuilt. Was ever year of manufacture that was not allergic to coolant, I am not sure.
I have mine filled with cutting oil (non corrosive/nonstaining) and like car2 I never use it, just apply a little once in a while when needed with a brush or squeeze bottle.
 
As Fred stated, water-based coolants are a no-no...only oil..Not only can water debond glued wear strips, but the lathe isn't designed to keep water out of other nooks and crannies, and the apron, gears, etc.
 
Thanks for the advice about the using oil only. I will certainly take better care of this machine than the previous owners did once it's running again.

I ended up disconnecting the motor wires and pulling everything out the top. Once it was out I was able to beat on piece #1 until it dislodged from the motor. There is a spline on the motor shaft that was holding the pump impeller. The crude build up on all this was keeping everything from coming apart easily.

Does anyone know if the spline on the motor shaft is supposed to come off? It kind of looks like there are two beefy c-clips holding it on. I'm puzzled as to how the plastic impeller was originally installed on that long motor shaft without messing it up because the spline is super fine.


1712508909467.png

1712508971746.png
1712509018860.png

1712509059224.png
 
You are welcome to the one I just pulled out of the dv59, for free, if needed and if you happen to be passing thru the Raleigh area, it looks in good shape. I don't want to mess with shipping it right now. I've never delved into taking one apart other than taking off the machine. Cheers, Charles
 








 
Back
Top