What's new
What's new

Hurco vm1 g43 issue

rob11256

Plastic
Joined
Apr 4, 2024
Location
New england
Hello I have a 2006 hurco vm1 with the ultimax MAX control and am having an issue using g43 to change offset height whenever I try and use the code g43 H1 H1 referencing tool 1 in the table I get the "error z height outside machine limits" also happens if I use a G44 or make the number in the tool table a positive or negative number and could really use some help figuring this out. Also I changed the H to an L and that didn't help with the issue. I can get the job done just changing the zero position number in the tool setup page but that won't always solve the problem either based on part size later on.
 

Attachments

  • 20240403_140329.jpg
    20240403_140329.jpg
    3 MB · Views: 2
  • 20240403_140307.jpg
    20240403_140307.jpg
    3.1 MB · Views: 2
  • 20240403_140152.jpg
    20240403_140152.jpg
    2.7 MB · Views: 2
On the Hurco control, there is another offsets page for the tool height offset. You need to touch your tool off and store that position on that page.

On the newer Winmax control, you don't need to touch it off on the tool height offset page if you don't call out a G43. I'm not sure if this works on the Ultimax machines or not, but you might try it. If you don't use G43, it will use the tool height from the tool set up page. Might be worth a try, we had upgraded all of our Hurcos to Winmax prior to me knowing this fact.
 
So setting the tool zero calibration into the tool number alot on tool length offset page does work however you can just hit .005, - ,then enter and it will -.005 from the tool zero calibration number and work just like G43 and using the tool length offset page.
 








 
Back
Top