What's new
What's new

Hyundai Kia SKT210sy strange sub spindle behavior, M-code request


Feb 22, 2019
Colorado, USA
Hello everyone,

(some background)
I recently purchased a Hyundai Kia (WIA)? SKT210sy with a FANUC 18i-TB (sub spindle, live tool, y axis, 2006) I got a great deal on it because it needed some work and I have already gone through and got a lot of things worked out. I have it running to the point that I can do turning and milling on the main spindle. So far all the problems have been parameter/control related not mechanical. (I am also spending a lot of time editing a post for it.)

My immediate question relates to the sub spindle synchronization process:
I am trying to sync the spindles in the most basic way just commanding them in MDI.
The main spindle uses M03/M04 for CW/CCW and the rotation makes sense to me. (I am using left hand tools, insert faces the operator, M04 direction)
The sub uses M113/M114 for CW/CCW, if you command M04/M114 the spindles spin in opposite directions. (they would try to twist your part into a twizzler)
This makes sense to me, I mean they are facing each other and both are rotating CCW. (from the chuck's perspective looking out toward the part) Is this what you would expect from a sub spindle lathe, to command M04,M113 to get them spinning together?

When I command:
G97 S50 M04
S50 M114
M160 (s1,s2 speed synchronization)

The spindles rotate counter to each other at first but when it sees the M160 the sub reverses and they spin together. At the M160 the program hangs. (presumably waiting for a speed sync signal)

If I command
G97 S50 M04
S50 M113

The spindles spin together, then at the M160 the sub reverses and they are spinning in opposite directions. The control still hangs waiting for a signal.

I have had the two sync with the first program (M04+M114) and not hang, but only a couple times and it seems intermittent. It seems like monkeying with the prox sensors on the sub might have caused some change in behavior, but it's hard to tell.
The other intermittent behavior is that at the M160 command the sub runs away and tries to spin to 6k rpm until I hit the reset button.
Once this happens if I try it again it does the same thing (ramps up to max) every time.

At this point I:

I cycle power on the control and get- 9087 SPN2 : S-SPINDLE ERROR (AL-087)

I cycle power on the control again and get-750 SPINDLE SERIAL LINK ERROR

I cycle power on the control again and it goes back to the original behavior of seemingly syncing the spindles but hanging at M160.

I just wanted to throw this out there and see if anyone has any ideas for me to try.

One of the things that I was told was "broken" when I bought this machine was the "turret alignment", and that it "wouldn't hold tolerances".
Turns out that whoever was screwing around in the parameters had changed the parameter for the turret motor's encoder type to incremental. It is definitely an absolute encoder, and the battery on the drive was dead. After I got a new battery, switched those parameters to match the drive/motor and reset the home position the turret is dead on and definitely holds tolerances.
I am giving this example because it seems to me that if someone did that then who knows what else they could have done. ie. is the sub running backwards or something?

Thanks for taking a look, I would be grateful for any suggestions. I'm sorry this is such a long post but it doesn't seem to be a simple problem to explain...Certainly I have no idea what is going on.

Also, if someone happens to have a more complete list of M-codes for this machine that would be very helpful. I have the hyundai operation manual but it is nowhere near complete.

Here is a quick update, I found some more indications that the sub spindle motor/drive/parameters aren't happy.
I tried to run a program on the sub, and it hangs at the G01 move following a G98. I also noticed that the sub spindle RPM readout on the control screen is way off, if the sub is running at 100 rpm the readout reads around 10. When I use the spindle override when I am just spinning the spindle in MDI the readout is off but responds backwards? When I turn up the speed the readout goes to around 4, and when I turn it down it goes up to 12 ish, it kind of flashes around.
The spindle/sub spindle system is an "ai" fanuc system, which I believe is serial?

Is it possible that the drive battery going dead cleared some settings?

Can anyone running a similar machine confirm the M113/M114 direction of their sub spindle?

Thanks again!
Problem solved.
I was randomly watching the spindle monitor screen for the sub spindle and scratching my head, jogging the sub (B axis) back and forth. I noticed that when I brought it far enough up towards the main spindle the speed reading would suddenly read correctly.
I pulled the cover off and tugged on the cable for the sub spindle encoder (magnetic? picks up a gear type steel wheel) and was able to make it read right when pushed down.
I pulled the cable out a couple feet and narrowed the problem down to about a 4 inch section that I could bend and relax to change the reading. Repaired the cable, (there were 3 different breaks in 2 of the conductors) and re assembled with the cable pulled out about a foot so that the point that the cable track bends repetitively is now on a "new" section of cable.
Everything seems to work peachy now, spindle sync works every time. Just thought I would post my problem and solution for future head scratchers.