What's new
What's new

Kimatura H400 15m - toolchanging and paramaters

hit the PMC button, go to PCMDI, then PALLET.

What do you see there?

This picture was taken while the machine was running, not during a pallet change.

20230530_094303.jpg

This would give you a rundown on signals the machine sees. If it is waiting for the door up switch, or one of the pallet lock switches to disengage, you'd see the status here.
 
the machine is recently purchased. we try it, it works well. after the graphics card is screwed so we all lost with . we changed it. for the program O9505 it makes the alarm PS 805 illegal command
 
I don't see a program 9505 in my backups. I have 9500, 9501, 9510, 9511, and 9512. I've never ran them because I've never lost the ATC but I believe all of these are for the ATC, as the atc is driven by a non-fanuc drive and this initializes the unit.

is 9505 for the APC?
 
Ok, so lets back up here. how are you trying to change pallets? with m-code?

I've never gotten the machine to change pallets successfully with the front switches you pictured earlier.

In MDI, M60 changes pallets no matter which pallet is in the machine. M71 will change to pallet 1, and M72 will change to pallet 2.

You likely have these macro programs for M60 (O9001), 71(O9002), 72(O9003), as well as 81(O9021) and 82 (O9022) But I will post them below, anyway.


What mcode are you using to try to change pallets?

Code:
O9001(AUTO PALLET CHANGE)
(VER 1.3 - FS/15M, H400B)
IF[#1002EQ1]GOTO1
IF[#1003EQ1]GOTO2
GOTO3
N1
IF[#1003EQ1]GOTO3
G65P9003
M99
 
N2
IF[#1002EQ1]GOTO3
G65P9002
M99
 
N3#3000=10(PALLET CHECK ALARM)
M30
 
O9002(LOAD PALLET #1)
(VER 1.3 - FS/15M, H400B)
#3=#4003
IF[#1002EQ1]GOTO10
IF[#1003EQ0]GOTO5
M11
M65
G91G28Z0.0
G28Y0
G28B0.0X0.0
M64
GOTO6
N5M11
M65
G91G28B0
N6G91G30X0.0Z0.0M65
M61
N10IF[#1003EQ1]GOTO20
G#3
M99
N20#3000=10(PALLET CHECK ALARM)
M30
O9003(LOAD PALLET #2)
(VER 1.3 - FS/15M, H400B)
#3=#4003
IF[#1003EQ1]GOTO10
IF[#1002EQ0]GOTO5
M11
M65
G91G28Z0.0
G28Y0
G28B0.0
G30X0.0Z0.0
M62
GOTO6
N5M11
N6G91G28X0.0Z0.0B0M65
M63
N10IF[#1002EQ1]GOTO20
G#3
M99
N20#3000=10(PALLET CHECK ALARM)
M30
 
O9020(PALLET RECOGNITION MACRO)
(VER 1.3 - FS/15M, H400B)
G65P8998
IF[#1002EQ1]GOTO1
IF[#1003EQ1]GOTO2
GOTO3
N1
IF[#1003EQ1]GOTO3
IF[#101EQ0]GOTO4
#149=#101
M99
 
N2
IF[#1002EQ1]GOTO3
IF[#102EQ0]GOTO4
#149=#102
M99
 
N3#3000=10(MACRO PALLET CHECK ALARM)
M30
 
N4#3000=11(NO PROGRAM SELECTED)
M30
 
O9021(PALLET #1 CHECK)
(VER 1.3 - FS/15M, H400B)
IF[#1002NE1]GOTO1
IF[#1003EQ1]GOTO2
M99
 
N1#3000=12(WRONG PALLET ALARM)
M30
 
N2#3000=10(MACRO PALLET CHECK ALARM)
M30
 
O9022(PALLET #2 CHECK)
(VER 1.3 - FS/15M, H400B)
IF[#1003NE1]GOTO1
IF[#1002EQ1]GOTO2
M99
 
N1#3000=12(WRONG PALLET ALARM)
M30
 
N2#3000=10(MACRO PALLET CHECK ALARM)
M30
 
Also, you mentioned getting an alarm from running 9505, that's probably because the first line should be G65 not G95.

That shouldn't affect your pallet change, unless there were some pmc paramters that were not correctly set. Did you actually lose the PMC parameters too? Or did you only lose the CNC memory? I can't recall if they are stored in the same place.
 
I don't know. Post pictures of all of your PMC data parameters, and keep relays.

I notice your pallet change arm (considered the W axis on my machine) is at or near "home", and not in the resting position.

I wonder if you have the APC maintenance mode turned on? You must have had it turned on at one point to home out that pallet change arm.
 
the arm she is at the origin. does the waiting position have a code??? it's a W axis. we used the maintenance mode to adjust the position...
 
Are you positive it is no longer in maintenance mode?

The ladder tells the W to go to wait in the waiting position. The waiting position is set in the data PMC parameters. So is the forward position.
 
Last edited:
There . I am looking for where it is defined. I believe that the position of the arm must be in the waiting position
 
More familiar with the 16/18M than the 15M, but that Data page looks like the Group Data Page and not the actual Data assigned in those groups. Are there not more pages to the Data tables? I don't see a GDATA key so maybe its on the following pages?

Or maybe it's just completely different then a 16/18M.
 
Ok, so comparing notes and my keepers (I have a lot more on to change behavior), but you have k16 bit 0 off, but it should be on per the manual and my parameters. It specifies crt type, color LCD. I do not know what it affects but I wonder if the PCMDI page not working is related to that setting?

Also the book says k16 bit 1 should be a 1, but doesn't say what it is. it is turned on in my machine.

Also, you shouldn't have RAM ENABLE (k17 bit 7) on. Not positive that will solve your issue. Doubtful. For reference, my book says K17 should be all 0's but my machine is K17 00101010

13engines is right, there are 10 data tables after the first page which is "table control data". The data in your screen matches mine nearly identical. only one number is different and i don't think that one is the problem (the "30" under "8192" is 0 on mine)
 
Those all look good to me compared to my machine.

I'd look at the few keepers I mentioned, see if switching those causes that PCMDI page to function for you.

If you don't get that pmc page to work to show you what signals the machine is seeing, I can explore i/o to see which signals the machine is seeing and expecting.


If you are running M60 in MDI or a program and it gets stuck at m64, if the above suggestion doesn't work, the next thing you would need to look at is the ladder, at or around the rung R5.3 and R22.7 and see what isn't satisfied. Here's a picture out of the ladder that I have.


1685630724133.png

Do you have a copy of the ladder and electrical manuals?
 

Attachments

  • 1685630472943.png
    1685630472943.png
    142.4 KB · Views: 4








 
Back
Top