What's new
What's new

Laguna Smartshop 3 Fanuc tool release not working

dstanley

Plastic
Joined
Nov 2, 2023
For background: Machine is a Laguna Smartshop 3, 5 axis with Fanuc Oi-MF. Operator (me) has been running this machine and only this machine for about a year and a half on a regular basis, I also design the files I run on Solidworks/SolidCAM.

The rundown of what was happening before the issue:

I started the machine, referenced all axis, and ran a program. No issues, everything ran as normal. The machine put the tool back as the program calls for and I loaded up the next file. I hit cycle start, the machine picked up the tool it was supposed to and the gantry began moving toward the work piece, however before it began its descent into the work I noticed I had a different tool in the tool holder spot I had just pulled from. (I have two sets of tools, but only 8 automatic changer locations. I have a set 1-8 A and 1-8 B and the program I was running was calling T4 (A) an engraving bit, while I had T4 (B) an end mill loaded in that spot. So before the spindle began to move down I hit cycle stop and reset then put it into MDI mode and told the machine to put the tool back by hitting M6T0, which usually works to put it back to no tool.

Description of issue:

The machine moved back to the correct position on the automatic tool changer, but when the g-code was running M21 (unclamp spindle) was called on the screen, the air is flowing as it normally does when a tool is released, and the tool is not releasing. The machine will sit there with the air flowing and paused since the M21 function doesn't finish so the next line in the program won't run. The only other time this has happened to where the tool won't release is if I forget to turn on my compressor, or for some reason it has turned off during work. Then it would sit there in the tool change position for some time until the air pressure has built up to where it has sufficient air to release and then it will continue from the M21 command and finish as would be expected to based on whatever I'm running.

Troubleshooting I have already tried:

-I have tried to manually remove the tool holder by releasing it using the manual button located by the spindle while in jog mode, which also usually works, but no dice. The sounds that occur are what normally happens, you can hear the click of the machine acknowledging the command to release, and the air begin to push out of the spindle, but the unclamping doesn't happen.
-I have tried to manually call M21 from mdi and no luck with that either.
I've tried turning everything off, re referencing, running the mdi program again as well as manually trying to release and still nothing.
-I've looked at all connections, electrical and pneumatic and everything is intact, no breakers tripped or anything, everything else is running normally except for this one command it seems. Any ideas?


As I'm writing, the machine currently shows there's no tool, but if I try to run the program I had originally loaded and ran with no issues, the gantry will move from where it's sitting and try to take T4 (which is obviously still in the spindle) to the work piece to begin the program. I hit cycle stop and reset and try to take it out again. If I try to enter a new tool using the mdi M6T3 for instance, it won't move because the machine then shows that it knows it already has a tool.

Any ideas? Thanks in advance for any help and insight provided!
 

Attachments

  • IMG_9006.jpg
    IMG_9006.jpg
    42.9 KB · Views: 0
  • IMG_9005.jpg
    IMG_9005.jpg
    61.2 KB · Views: 0
  • IMG_9001.jpg
    IMG_9001.jpg
    68.6 KB · Views: 0
  • IMG_8999.jpg
    IMG_8999.jpg
    67 KB · Views: 0
Still looking for help on this issue. I've gone into the parameters of the machine and taken some more pics and have more detail that might be helpful.

I'm now getting an error that states : "SV0368 (C) serial data error (INT)"

I've changed out the D cell batteries on the back as well as checked all connections for the servo motors/pulse encoders and everything seems fine.

Another thing I'm noticing is that the machine seems to be thinking its moving

Diagnostics parameter 0300 "servo error" shows the X axis switching between 1 and 0 repeatedly, and parameter 0550 "full closed loop error" doing the same thing.

Are these related to the above initial issue as to why the collet isn't opening or something completely different?
 

Attachments

  • IMG_9021.jpg
    IMG_9021.jpg
    1.6 MB · Views: 1
  • IMG_9019.jpg
    IMG_9019.jpg
    1.9 MB · Views: 1
  • IMG_9018.jpg
    IMG_9018.jpg
    1.9 MB · Views: 0
  • IMG_9016.jpg
    IMG_9016.jpg
    3.9 MB · Views: 0
  • IMG_9026.jpg
    IMG_9026.jpg
    1.8 MB · Views: 0
  • IMG_9028.jpg
    IMG_9028.jpg
    2 MB · Views: 0
  • IMG_9032.jpg
    IMG_9032.jpg
    2 MB · Views: 0
  • IMG_9029.jpg
    IMG_9029.jpg
    2 MB · Views: 0
  • IMG_9027.jpg
    IMG_9027.jpg
    1.9 MB · Views: 0
  • IMG_9022.jpg
    IMG_9022.jpg
    1.6 MB · Views: 1








 
Back
Top