What's new
What's new

Leblond Makino

70olds

Aluminum
Joined
Jun 21, 2016
I am looking at a Leblond Makino for my garage. It's a mid-80s machine that is in running condition. I can get it real cheap and have a friend who will rig it for free so the only chance I am taking is on the machine itself. As I understand it, the name change was nothing more than that, it wasn't someone buying out someone else and the machine will be totally different. Anyone run any of these old machines? The control is a Fanuc 6M. I am not a FANUC guy but for old equipment it's probably my best bet. Is there any major limitations to this control other than memory? Thanks.
 
I ran one from the 80's, It was a pretty solid built machine.
The only issue we had was the tool changer, It was like it and the control never communicated, we had nights we got nothing done when we first started running it. It took awhile to figure it out.
 
We didnt do much of that back then, I kinda thing it would. I remember that it had the longest spindle drift when tapping.
It would stretch that spring holder to the max.
 
Would that control have helical interpolation for threadmilling?
Depends on the model 6MA or 6MB. 6MB could if the option was spec’d originally or turned on later.

LeBlond Makino was formed when Makino bought out Leblond. The company was run under the merged name for a few years and then the LeBlond was dropped.

Good solid machines when new, one of the best. Is the machine you are looking at an FNC74 maybe?
 
Last edited:
6MB does helical interpolation just fine. Most 6M's are 6MB's. 6MA was pretty early. Like 1980/81. 6MB was around 82-85 or so. Tons of machines were made with that control in that timeframe.

IMO, 6MB is just fine if you are willing to take the time to replace all the electrolytic capacitors in the drives and power supplies. 40 years is easily twice the lifespan of these parts, but they can be re-capped for very low cost if you DIY it.
 
You are correct, ours is still here, mechanically ok. The electronics is why it isn't running.
 
Yeah, 6M really is dirt simple and it's a hell of a lot better control than any PC based thing you could find.

The fact there's still a ton of them running 40 years after they were made is a testament alone.
 
I agree.
The funny thing was when they went to replace it with an OKK, the owner got the the Z travel distance wrong and we still cannot run the parts that used to run on the Leblond.
 
I got the machine in the garage and powered up. After spending an hour trying to figure out why it wouldn't be "ready" I realized I was on an axis limit and that doesn't work. Then I figured out I had to hold the overtravel release button for a few seconds before it would kick in so I could pulse handle off the limit before i could zero return the machine. I tried running the program on the control to set the tools and after the first M57 T-command this button lights up on the control and I don't know what it's telling me but I cant get anywhere in the program to finish setting the tool pots. I don't have a 6M book, only one for an 11M, but this button id not addressed in those manuals. Any idea what this is trying to tell me?
 

Attachments

  • controlpicture.jpg
    controlpicture.jpg
    235.7 KB · Views: 10
Some of the older Makinos require you MDI the spindle tool.

I don't know what the M57 deal is, but on mine with a 15M I have to MDI the spindle tool even though it knows what it is. If T1 is in the spindle I just MDI T1, EOB, INSERT, START.

If I don't do that it will alarm out as soon as there's an M6.
 
I’ll give that a shot. My machine already had the program in it with the M57 tool assignments so I assumed it was formatted correctly. Any ideas as to what that button does/what that symbol is?
 
M57 on older Makino machines lets one assign tool numbers to pots programatically. IME, few places used it. From a maintenance standpoint it was an easy way to reset the tool table ie; tool 1 in pot 1 and so on.
 
Last edited:
M57 on older Makino machines lets one assign tool numbers to pots programatically. IME, few places used it. From a maintenance standpoint it was an easy way to reset the tool table ie; tool 1 in pot 1 and so on.
On this machine it forgets every time the machine is power cycled. I was told by the previous owner I have to run it every time otherwise the machine won't ever do a tool change without getting stuck. There's a little display on the side of the control that lists the current tool number that is blinking. This program is supposed to stop that from blinking as it firms up what tool is in the spindle. Only then can you do tool changes.
 
Little progress. I was able to get the machine to run through MOST of my M57 Pot setting program. I cleared the CMOS and got through the entire program a couple times, then after that could only get through up to pot 11 for some reason before getting the same alarm as above. I am not aware of what that symbol is, and I have no errors on the diagnostic LED board on the electrical cabinet, no alarms on screen. Since I kept getting stuck at tool 11 I ended the program after 3 tools which left me with the ability to define that tool 2 was in the spindle, and 1 and 3 were in the carousel. After orienting the carousel and verifying that the "SPINDLE/POT" switch on the side of the control knew both tools were there I tried a tool change and it wanted to go but got stuck right before it grabbed both tools with the arm, with the same button lighting up on the control. Until find out what that is I fear I am dead in the water with tool changes.

I was able to start up, zero return, run the spindle, move the machine through handle, MDI, memory, I think the only thing I can't seem to get to function is the tool changer right now.
 
The tool change issue was a real challenge for us when we first got it. I do remember running that program like you said after cycling power.
I will try to find out form the one guy here that could actually run that it.
 








 
Back
Top