What's new
What's new

Need Help! Kitamura zero - ATC - fanuc 0m


Jan 8, 2024
Hi ALL, I recently acquired a Kitamura Mycenter zero which I want to use for my hobby.
After fixing the Y+ overtravel issue here: Practical Machinist it is time to fix the primary issue with this machine; the non-working atc.

Video of the issue occurring:

Machine: Kitamura Mycenter zero 1992 8k rpm
Controller: Fanuc 0m

Sequence of events:
1. power on
2. home x,y,z
3. change to MDI
4. Type T5 insert
5. Type M6 insert
6. output start
7. spindle indexes (already has the correct tool in POT)
8. Fanuc 1005 alarm - Motor thermal protection - Kitamura 5 alarm "Thermal trip (power panel)"

What I have observed to work (in separate T6; M6 runs)
- Atc carousel turning to the correct tool;
- Picking a new tool from the carousel
- Spindle indexing
- Unclamping and clamping of new tools (manually)

What I have not observed to work:
- ATC CAM arm (note: in the run in the video I disconnected it as I thought that was the issue, but it is not)

What I have tried:
- To reset the thermal trip alarm; one must reset the thermal protection. As demonstrated in the video I have done that for (there is no obvious indicator that it tripped).
In the video I reset all the thermal protections that are accessible:
MS1/OL1 - lubrication unit
MS4/OL4 - ATC cam motor

- Disconnected the coolant pump (MS2/OL2)- no effect
- Disconnected the lubrication pump (MS1/OL1) - no effect
- ATC magazine motor has thermal overload OL3 - this is not connected to the control from what I can see)

What I have noticed:
As far as I'm aware this is the ATC CAM inverter that interacts with the Fanuc 0m;
The red led blinks 5 times when the issue has occurred; this is the same Kitamura error number as on the 7-segment display in the front.
When i disconnect wire 19 and 31 the machine (fanuc + Kitamura display) will always be in a thermal alarm state. -> This seems to point out that this is where the error occurs.

I can measure a voltage change between these two wires when it is in alarm state and when it is not.
Now I'm thinking about it ... this must be the issue; but what i find strange is that i still get a thermal alarm while the motor is not even connected.

Has anybody experienced this before? and or have tips to help me out? that would be amazing!

So.. I have figured out that the ATC Cam motor is indeed the issue.
It is a Yaskawa CIMR-04AS ; I requested the schematics from them but supposedly they don't have it.

The internal thermal signal is the alarm message. Non of the phases short to ground so the IGBT itself seems alright.

R2 was broken:

One thing i find strange is that i don't see any burnt spots there. I'm going to fix the damaged PCB trace and replace the R2 resistor and see if it works.
Else I will just put another small VFD on there as the interface to it is very limited.