What's new
What's new

New machine on order.

The machine should come with all fluids topped off. You shouldn't need any immediately. But you will need the DTE oil light soon, as that's for the spindle lube.
 
Grease? Does that mean you have to grease the linear slideway trucks on the X and Z axis? Or is that for the chuck? Is their no conversational ability on these lathes?
 
Grease? Does that mean you have to grease the linear slideway trucks on the X and Z axis? Or is that for the chuck? Is their no conversational ability on these lathes?

Have to grease X, Y and Z about twice a year. There is a maintenance schedule in the control and it will notify you when to do so.
 
Yes there is.
If you go into manual mode, then "machine operation" (the key to the left of cycle start) you can hit "Return Cycle". This clears any next tool callup that is staged.

This doesn't remove the tool from the spindle and leave it empty.

If you use the macro it doesn't matter if a tool is staged and you call a different tool, it will work. I've tried every thing I could think of to mess up the toolchange and haven't been able to.
 
This doesn't remove the tool from the spindle and leave it empty.

If you use the macro it doesn't matter if a tool is staged and you call a different tool, it will work. I've tried every thing I could think of to mess up the toolchange and haven't been able to.

No there is an M code for that, I can't remember what it is offhand. I've really never needed a use for that though. But everyone does stuff different ways. lol
 
No there is an M code for that, I can't remember what it is offhand. I've really never needed a use for that though. But everyone does stuff different ways. lol

Really, what is it. Because I asked our apps guy and he said it wasn't possible. Then he modified our toolchange macro.

:toetap:
 
Really, what is it. Because I asked our apps guy and he said it wasn't possible. Then he modified our toolchange macro.

:toetap:

I swear he said he used an M code to make the spindle tool T0 or to unload a tool. Because while he went to lunch, I couldn't figure out what he did as I couldn't change tools. And I've been running Okumas since 1996 lol.
 
For someone with no Okuma experience, is it as simple as MDI mode, G111 and cycle start?

Yeah, you got it. About the only way to mess up the tool change sequence on an Okuma is to switch to manual mode out of MDI in the middle of a toolchange command. Even that is not a bad fix, the toolchanger has its own button on the control, and softkeys to single step forward or backward through the toolchange sequencing.
 
That doesn't work with my mills. Can you post your toolchange macro so I can have a look.

What are the A and R values?

A - Tool desired in spindle

R - Tool in ready position

OTC2
M132
(MDI CHECK)
IF[VORD[0042] NE 1]NAUTO
IF[PP EQ EMPTY]NAUTO
IF[PP LE 0]NAUTO
NXYPS
PX=VAPAX-VMOFX-VZOFX[VACOD]
PY=VAPAY-VMOFY-VZOFY[VACOD]
NAUTO
IF[PA NE EMPTY]NJPR
PA=0
NJPR IF[PR NE EMPTY]NPAPR
PR=0
NPAPR IF[PR NE PA]NJ01
PR=0
NJ01 IF[PH NE EMPTY]NJ03
PH=PA
NJ03 G56 H=PH
IF[PA NE 0]NJ19
IF[PR NE 0]NJ12
IF[VNTOL EQ 0]NJ08
M64
NJ08 IF[VTLCN EQ 0]NJ11
M63
M06
NJ11 GOTO NEND
NJ12 IF[VNTOL EQ 0]NJ14
M64
NJ14 IF[VTLCN EQ 0]NJ17
M63
M06
NJ17 T=PR
GOTO NJ38
NJ19 IF[VTLCN NE PA]NJ26
IF[VNTOL EQ PR]NJ38
IF[VNTOL EQ 0]NJ23
M64
NJ23 IF[PR EQ 0]NJ38
T=PR
GOTO NJ38
NJ26 IF[VNTOL NE PA]NJ31
M06
IF[PR EQ 0]NJ38
T=PR
GOTO NJ38
NJ31 IF[VNTOL EQ 0]NJ34
M64
NJ34 T=PA
NJ35 M06
IF[PR EQ 0]NJ38
T=PR
NJ38 IF[PS EQ EMPTY]NEND
S=PS
IF[PV EQ EMPTY]NEND
IF[PV NE 3]NJ43
M3
NJ43 IF[PV NE 4]NEND
M4
NEND
IF[PX EQ EMPTY]NRTS
G0 X=PX Y=PY
NRTS M133
RTS
 
A - Tool desired in spindle

R - Tool in ready position

OTC2
M132
(MDI CHECK)
IF[VORD[0042] NE 1]NAUTO
IF[PP EQ EMPTY]NAUTO
IF[PP LE 0]NAUTO
NXYPS
PX=VAPAX-VMOFX-VZOFX[VACOD]
PY=VAPAY-VMOFY-VZOFY[VACOD]
NAUTO
IF[PA NE EMPTY]NJPR
PA=0
NJPR IF[PR NE EMPTY]NPAPR
PR=0
NPAPR IF[PR NE PA]NJ01
PR=0
NJ01 IF[PH NE EMPTY]NJ03
PH=PA
NJ03 G56 H=PH
IF[PA NE 0]NJ19
IF[PR NE 0]NJ12
IF[VNTOL EQ 0]NJ08
M64
NJ08 IF[VTLCN EQ 0]NJ11
M63
M06
NJ11 GOTO NEND
NJ12 IF[VNTOL EQ 0]NJ14
M64
NJ14 IF[VTLCN EQ 0]NJ17
M63
M06
NJ17 T=PR
GOTO NJ38
NJ19 IF[VTLCN NE PA]NJ26
IF[VNTOL EQ PR]NJ38
IF[VNTOL EQ 0]NJ23
M64
NJ23 IF[PR EQ 0]NJ38
T=PR
GOTO NJ38
NJ26 IF[VNTOL NE PA]NJ31
M06
IF[PR EQ 0]NJ38
T=PR
GOTO NJ38
NJ31 IF[VNTOL EQ 0]NJ34
M64
NJ34 T=PA
NJ35 M06
IF[PR EQ 0]NJ38
T=PR
NJ38 IF[PS EQ EMPTY]NEND
S=PS
IF[PV EQ EMPTY]NEND
IF[PV NE 3]NJ43
M3
NJ43 IF[PV NE 4]NEND
M4
NEND
IF[PX EQ EMPTY]NRTS
G0 X=PX Y=PY
NRTS M133
RTS

That's one helluva toolchange macro! Curious as to what all it's doing as I don't even use a macro.
 
HI , we just purchased on under a year ago.

To answer your question, Grainger will have all necessary fluids for this machine. or MSC industrial.
You will also need 8 block aprox, 2.500 long x 2.500 square to have them mount it to the floor. they don't tell you this. and will hold you up another day.
We use Master cam for off line programming, works very well with okuma for posting programs.



Kenny g !




HI guys,

We just purchased a new Okuma Genos M560 that will be delivered hopefully by the end of next week if all goes well.

I'm sure I'll be picking your brains as we get this new machine up and running but just a few basic questions for now.

Okuma send a list of all the fluids that will need to have on hand before the tech starts the install and a few of them I'm not familiar with or where is the best place to purchase.

Exxon Mobil DTE Oil Light looks like available most places in 5 Gal pails.

Where do you buy the following?

FC2 (Exxon Mobil Velocite Oil No.3, for example) needs 5 Gal.

THK AFJ GREASE Looks like it needs to be in 400 cc tubes.

CKC150 for the ATC cam box, 2.1 Gal.

HM32 380 CC for the tool unclamp package


Additionally, I'll need to be working on a post processor so if anyone can provide a G and M code list for a P300 control that would be awesome, Google just isn't showing any decent results.

Thanks, Dave
 
For someone with no Okuma experience, is it as simple as MDI mode, G111 and cycle start?

First you have to have a macro setup. If your macro is setup to take the tool out of the spindle with just a G111 than thats it. My macro is setup for a G111 T0 you can also prestage with it G111 T0 Q1.

It's not as complicated as it seems. When your apps engineer shows up show him these G111 macros and have him set one up. He probably has one of his own too.
 
What machines are you running w/o a macro?

I have 2 Genos M560V's with no macro. Haven't had an issue.
If there isn't a tool in the spindle and I need to index, I simply use the M329 command in MDI and then a tool change.
 








 
Back
Top