What's new
What's new

Parámetros de roscado, ¿Mi cnc no rosca?

Acamba472

Plastic
Joined
May 22, 2024
Location
Venezuela
Benas tardes compañeros, Dios los bendiga.
Tengo un control fanuc serie OM que perdió todos sus parámetros, la máquina trabaja perfectamente todos los procesos de mecanizados con excepción del proceso de roscado. Al intentar roscar la máquina se ubica en las coordenadas pero no ejecuta su desplazamiento en Z con el paso específico. Se utilizo el G76 y el G92, con los cuales no ejecutó el proceso. Alguien puede orientarme, pienso que son parámetros lo que está sucediendo.

Se les agradece con antelación.

Bendiciones..!!!
 

Attachments

  • 17163849666217901884316484831913.jpg
    17163849666217901884316484831913.jpg
    4.5 MB · Views: 4
Translated:

Good afternoons comrades, God bless you. I have an OM series fanuc control that lost all its parameters, the machine works perfectly all machining processes except for the threading process. When trying to thread, the machine is located at the coordinates but does not execute its Z-movement with the specific step. The G76 and G92 were used, with which he did not execute the process. Someone can guide me, I think it's parameters that's happening. Thank you in advance. Blessings..!!!
 
Muéstrenos el código tal como está escrito en el control del ciclo de enhebrado.
Please show us the code as written on the control for the threading cycle.
 
Muéstrenos el código tal como está escrito en el control del ciclo de enhebrado.
Muéstrenos el código tal como está escrito en el control del ciclo de enhebrado.

Muéstrenos el código tal como está escrito en el control del ciclo de enhebrado.
Muéstrenos el código tal como está escrito en el control del ciclo de enhebrado.


Mi amigo le adjunto parte del codigo utilizado, sea con g76 o con G92 Ninguno de los dos ejecuta. Resaltó que antes de perder los parámetros la máquina, trabajaba con ambos códigos de roscado.
 

Attachments

  • 17164007916548851139556729918158.jpg
    17164007916548851139556729918158.jpg
    6.9 MB · Views: 4
0M y G76?

Creo que estás usando la codificación incorrecta.


------------------

¡Soy Ox y apruebo esta publicación aqui!
La máquina antes de la falla ejecutaba ciclos de enlatado sin problema. De igual manera ambos códigos de roscado. Pero creés que pueda ser cuestión de código?
 
Before the failure, the machine executed canning cycles without problem. Likewise both threading codes. But do you think it could be a code issue?

Not sure exactly how to code a tap on a Fanuc "mill", but I would assume it to be G85 or some such code.
No?

G76 is only a lathe code.

You said that it is a "0M" control - which designates that this is a "mill" (M) that you are running.
Maybe this is a "0T" control on a lathe?


---------------------

I am Ox and I approve this here post!
 
Last edited:
I see now that you added your code.
So, it appears that this IS a lathe (0T control)

So, it appears that your G92 line is highlighted.
Is that where you are hanging?
Did it run the G76 code?

I'm not even sure what G92 is on a lathe?
I would have to look that up.
90+ % of my job is running Fanuc lathes, and I don't use G92.


---------------------

I am Ox and I approve this here post!
 
No estoy seguro exactamente de cómo codificar un grifo en un "molino" Fanuc, pero supongo que es G85 o algún código similar.
¿No?

G76 es sólo un código de torno.

Usted dijo que es un control "0M", lo que indica que se trata de un "molino" (M) que está ejecutando.
¿Quizás este sea un control "0T" en un torno?


---------------------

¡Soy Ox y apruebo esta publicación aquí!

Efectivamente es un torno, generalmente usan ese tipo de códigos con este control donde G76 es enlatado de roscado y G92 ciclo de roscado. Ninguno de los dos se ejecuta.
 
Disculpen por no explicarme bien, es un torno con control fanuc. Puede que si lo pudieron haber cambiado.


If you search the net for option parameters for 0T control, you may be able to find a listing posted somewhere.
You likely need to update some of the 900 (9000?) parameters.


------------------

I am Ox and I approve this here post!
 
Si busca en la red parámetros de opciones para el control 0T, es posible que pueda encontrar una lista publicada en algún lugar.
Probablemente necesites actualizar algunos de los 900 (¿9000?) parámetros.


------------------

¡Soy Ox y apruebo esta publicación aquí!

Encontre un archivo con 900 parámetros opcionales, pero no concuerdan del todo con esta máquina, pareciera que era para un centro mecanizado.

Seguire buscando a ver si consigo alguno que me habilite el roscado.
 
If you find that your option is turned on, then my next question would be - How is it responding?

Are you getting an error on the screen stating that the G code does not exist?
Or, is it rapiding up to the start point, and hanging there with no alarm?

If the second - then it is likely looking for spindle encoder feedback.
Maybe your encoder went bad?
Maybe a belt to the encoder broke?
Maybe a board in the unit is bad?

This will be a stand-alone encoder.
Not just the one in the spindle motor.


-------------------

I am Ox and I approve this here post!
 
If you find that your option is turned on, then my next question would be - How is it responding?

Are you getting an error on the screen stating that the G code does not exist?
Or, is it rapiding up to the start point, and hanging there with no alarm?

If the second - then it is likely looking for spindle encoder feedback.
Maybe your encoder went bad?
Maybe a belt to the encoder broke?
Maybe a board in the unit is bad?

This will be a stand-alone encoder.
Not just the one in the spindle motor.


-------------------

I am Ox and I approve this here post!


Posee un encoder unicamente del husillo, revise pulsos y emite. Programo avance por revolucion y trabaja la maquina. Cuando ejecuto el codigo de roscado, la maquina se ubica en el punto de inicio y baja en las coordenadas expresadas en x, es decir el programa sigue ejecutando unicamente que no desplaza en z (esto usando el G92). Usando el G76 no se mueve la maquina, se ubica en la coordenada de inicio y no realiza ningun movimiento. Todo esto sin generar una sola alarma.
 
It has an encoder only for the spindle, it checks pulses and emits. I program advance per revolution and the machine works. When I execute the threading code, the machine is located at the starting point and descends in the coordinates expressed in x, that is, the program continues executing only that it does not move in z (this using the G92). Using the G76 the machine does not move, it is located at the start coordinate and does not make any movement. All this without generating a single alarm.


Then your problem in in your spindle encoder feedback loop somewhere.

It would be nice of you to do the translation for us so that it's not so much work to help you.


------------------

Think Snow Eh!
Ox
 
Entonces su problema está en algún lugar del circuito de retroalimentación del codificador de husillo.

Sería lindo que nos hicieras la traducción para que no sea tanto trabajo ayudarte.


------------------

Piensa en la nieve ¡Eh!
Buey

DISCULPEN, NO ME DI CUENTA QUE NO SE TRADUCE AUTOMATICAMENTE PORQUE TODO LO DE LA PAGINA YA ESTA TRADUCIDO.

Verificaré la conexión del codificador y verificaré sus salidas. La lectura de revoluciones se lee correctamente en el control. Por esa razón no pensé que sería el codificador. Por supuesto también que todo el fallo parte de la pérdida de parámetros.
 








 
Back
Top